[Error] Install Midori 0.4.4-1~lucid~ppa1_i386

Beberapa waktu lalu saya ditemui error saat install Midori 0.4.4-1 di Ubuntu 10.04 dari ppa launchpad. Midori adalah web browser andalan untuk membuka website/blog versi mobile. Error yang muncul adalah “subprocess new pre-installation script returned error exit status 127“.

Sudah mencoba cara yang pernah saya lakukan tapi tidak berhasil mengatasi error. Menghapus file .deb dan mencoba install ulang tidak membantu, install dari repository lokal apalagi. Error ini sebelumnya tidak begitu mengganggu sampai akhirnya tadi malam (26 Maret 2012) kesabaran saya habis, error ini mengganggu instalasi radio streaming server.

Akhirnya setelah cari kesana-kemari ketemu juga solusi jitu mengatasi error tersebut, kali ini saya menggunakan mode GUI.

  • buka direktori /var/cache/apt/archives.
  • hapus file midori_0.4.4-1~lucid~ppa1_i386.deb.
  • setelah file tersebut terhapus kemudian menuju direktori /var/lib/dpkg/info.
  • cari semua file yang “berbau” Midori dan hapus.
  • jika ingin menggunakan mode CLI dengan perintah:
ls | grep midori
sudo dpkg --remove --force-remove-reinstreq midori

Alhamdulillah yah sesuatu.., error tersebut tidak muncul lagi :mrgreen:

Referensi:
askubuntu